We’re sorry but we are currently still working on support for IE6 because of its non-compliance with common web standards. In the meantime, please consider upgrading to Internet Explorer 7, FireFox, Apple Safari, or Google Chrome.

TWH »

Empire: Total War Heaven



  You must be logged in to post messages.
Please login or register

Technical Help and Bug Reporting
Moderated by Pitt, Awesome Eagle

Hop to:    
Welcome! You are not logged in. Please Login or Register.350 replies
Empire: Total War Heaven » Forums » Technical Help and Bug Reporting » Can I run ETW? (thread)
Bottom
Topic Subject:Can I run ETW? (thread)
« Previous Page  1 ··· 5 6 7  Next Page »
Waffentraeger
Mariner
(id: Daelon)
posted 12-04-08 09:53 AM EDT (US)         
This is the "Can I run ETW" thread.
Please post either your DxDiag (Go to start > run > DxDiag, save then upload). Or post the detailed specs of your pc.

And have a fantastic day!

[This message has been edited by Daelon (edited 09-11-2009 @ 10:53 PM).]

AuthorReplies:
BlackwatchGuards
Mariner
posted 03-29-09 07:06 PM EDT (US)     301 / 350       
whoops, I already put this on "minimum specs" but....
What graphics settings will I be able to play ETW on?
Intel Core 2 Duo 2.66GHz (2 CPU'S)
2 GB RAM
7300 SE/ 7200 GS 512 mb (going to get a 9800 GT though)
Thanks in advamce.
Waffentraeger
Mariner
(id: Daelon)
posted 03-29-09 08:52 PM EDT (US)     302 / 350       
Upgrade to the 9800GT first, than you'll be fine.
Zakc44j63
Mariner
posted 04-08-09 09:27 AM EDT (US)     303 / 350       
I have tried to run the demo, I downloaded it from Steam, but I think it is corrupted.(There is no text at all ingame)
minimum requirements:
* CPU: 2.6Ghz single core processor
* RAM: 1GB RAM (2GB for Vista)
* Graphics: a DirectX 9.0c card with 256mb RAM
my system:
* CPU: 1.83Ghz dual core processor
* Ram: 3GB RAM (Vista)
* Graphics: Intel 965 Chipset Family (358 mb Ram)
DirectX 10 installed

My computer is old and I have had problems with other games, does anyone have a Intel 965 Chipset and is still able to run the game. (low is okay)
Waffentraeger
Mariner
(id: Daelon)
posted 04-08-09 09:45 AM EDT (US)     304 / 350       
You don't have a good enough graphics card. The onboard GPU that you have probably won't even load ETW.
Zakc44j63
Mariner
posted 04-08-09 05:05 PM EDT (US)     305 / 350       
I have been thinking of getting anew graphics card for a while, the NVIDIA GeForce 6150 SE is on sale, will that work?
Waffentraeger
Mariner
(id: Daelon)
posted 04-08-09 06:27 PM EDT (US)     306 / 350       
You wont even be able to load up the game with that.
Powder94
Mariner
posted 04-11-09 06:22 PM EDT (US)     307 / 350       
I have already tried running it but I just get a bunch of black and white lines running across the screen =(
But I'll see what you guys think

2.08 Ghz
1.18 GB RAM
Nvidia Geforce 8400 GS (512MB)

I updated the drivers and set the card to performance and still nothing
Waffentraeger
Mariner
(id: Daelon)
posted 04-11-09 06:31 PM EDT (US)     308 / 350       
1.18 GB RAM
I hope that is 1.18MB of RAM, and how is it 1.18?

You need more RAM, and what kind of CPU is that?
Powder94
Mariner
posted 04-11-09 06:49 PM EDT (US)     309 / 350       
Sorry bout this but I'm a newb when it comes to computers but this is what my computer says, "2.08Ghz, 1.18GB of RAM" and it's 1.18 because I put more memory in it. And I don't now if this is what your looking for "AMD Athlon(tm)XP 2008+" otherwise I have no clue what CPU I have
Waffentraeger
Mariner
(id: Daelon)
posted 04-11-09 08:18 PM EDT (US)     310 / 350       
Upgrade the RAM completely. 1.18 is a very odd number for MB's. You need at least 2mb of RAM.
Powder94
Mariner
posted 04-11-09 09:38 PM EDT (US)     311 / 350       
k thanks for the help
Zakkeh
Mariner
posted 04-15-09 06:29 AM EDT (US)     312 / 350       
Hey, I just wanted to know if this computer, with the correct drivers since I haven't got it yet, could run E:TW.

2 X 2048MB DDRII Ram (4GB)
500GB Sata II Hard Drive
512MB 9800GT PCIE Graphics
AC97 Sound

That's about the only computer specs I have at the moment, so considering that I'll update the drivers, what settings would that run E:TW on?

Thanks for any help.
Waffentraeger
Mariner
(id: Daelon)
posted 04-30-09 04:34 PM EDT (US)     313 / 350       
Please post either your DxDiag (Go to start > run > DxDiag, save then upload). Or post the detailed specs of your pc.
Hussarknight
Seraph Emeritus
posted 05-01-09 04:17 AM EDT (US)     314 / 350       
Zakkeh: that system can run ETW provided you add a CPU to it as well.

          Hussarknight
imlost
Mariner
posted 08-05-09 02:10 AM EDT (US)     315 / 350       
I wondering if this cpu would be acceptable for empire.
Athlon 64 X2 6000+
imlost
Mariner
posted 08-22-09 06:44 PM EDT (US)     316 / 350       
Was my question so stupid that nobody wants to dignify it with an answer?
Waffentraeger
Mariner
(id: Daelon)
posted 09-11-09 10:52 PM EDT (US)     317 / 350       
imlost your CPU will run ETW just fine.
NinjaWJ
Mariner
posted 09-21-09 11:16 PM EDT (US)     318 / 350       
Hi guys i was wondering if my comp can handle this game. Ive have downloaded the dmeo and was able to play it. I dont really care about graphics but i was wondering if this system can handle unit count set to ultra.

Windows Vista
AMD Phenom X4 9550 Quad-core processor
ATI Radeon HD 3200
6gb Ram

my main concenr is the vid card
Waffentraeger
Mariner
(id: Daelon)
posted 09-22-09 06:33 PM EDT (US)     319 / 350       
Yes you can most definitely run the game. Not sure about the settings but it can run it.
NH 208
Mariner
posted 01-09-10 03:09 PM EDT (US)     320 / 350       
these are my specs that i have
graphics card:ATi Radeon HD 2400 Pro
RAM:3.00 GB
System Type:32-bit operating system
Modelell XPS_420
Total aviable graphics memory:1406 MB
Dedicated video memory:128 MB
System video memory MB
Shared System Memory:1278

Thats all the info i have, and its probaly not enough to run the game, but itd be really nice for someone to tell me if its good enough and what i need to get and maybe how much it will cost
Waffentraeger
Mariner
(id: Daelon)
posted 01-09-10 06:14 PM EDT (US)     321 / 350       
You don't have enough VRam to run the game, and I can't tell you how much it'll cost to run it because I don't know your model of motherboard.
imlost
Mariner
posted 01-24-10 03:31 PM EDT (US)     322 / 350       
Hi,
I'm pretty much set to run this game but I'm concerned about my processor. Its a AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, MMX, 3DNow (2 CPUs), ~2.0GHz. Pretty sure this isn't good enough. I've been looking at getting this: http://www.amazon.com/AMD-Phenom-HDZ955FBGIBOX-125W-Processor/dp/B00275G0VE/ref=sr_1_5?ie=UTF8&s=electronics&qid=1264364923&sr=8-5
though I'm not sure if my motherboard is capable of upgrading to that. Its an MSI, model number MS-7325. I don't understand how to figure out whether what kind of cpu this can handle. Thanks for any help.
Waffentraeger
Mariner
(id: Daelon)
posted 01-24-10 03:33 PM EDT (US)     323 / 350       
That CPU is just fine for ETW. You shouldn't have a problem.
fwembt
Mariner
posted 02-11-10 12:10 PM EDT (US)     324 / 350       
I really want to purchase this game during the special currently running on Steam. Does this computer have the ability to run it?

------------------
System Information
------------------
Time of this report: 2/11/2010, 12:01:29
Machine name: OWNER-PC
Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.090803-2339)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv7 Notebook PC
BIOS: Default System BIOS
Processor: AMD Turion(tm) X2 Dual-Core Mobile RM-72 (2 CPUs), ~2.1GHz
Memory: 3836MB RAM
Page File: 3440MB used, 4463MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
DxDiag Version: 7.00.6002.18107 32bit Unicode

---------------
Display Devices
---------------
Card name: ATI Radeon HD 3200 Graphics
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon HD 3200 Graphics (0x9612)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9612&SUBSYS_30FC103C&REV_00
Display Memory: 1916 MB
Dedicated Memory: 253 MB
Shared Memory: 1662 MB

Can You Run It? Thinks I can but it says "CPU Speed
Minimum: 2.4 GHz You Have: 2.09 GHz Performance Rated at: 3.553 GHz" and I am not sure what that means.
Waffentraeger
Mariner
(id: Daelon)
posted 02-11-10 06:45 PM EDT (US)     325 / 350       
Yeah you are all set to go. Shouldn't have a problem running the game. Normal troop levels @ medium graphic settings.
fwembt
Mariner
posted 02-11-10 07:41 PM EDT (US)     326 / 350       
Thanks for the quick response. This download is going to take ages.
Phalanxkiller
Mariner
posted 02-22-10 04:24 PM EDT (US)     327 / 350       
I bought the game at release last year. It ran generally well, and all of a sudden, it takes FOREVER to load a campaign and just freezes and lags. I've gotten fed up enough to the point where I'm just upgrading my computer.

If I don't have anything, please let me know and about how much it would cost me. Thanks.
__________________________________________
Time of this report: 2/22/2010, 16:17:34
Machine name: (MY NAME)-PC
Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.091208-0542)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Dell DXC061
BIOS: Phoenix ROM BIOS PLUS Version 1.10 2.2.1
Processor: Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz (2 CPUs), ~1.9GHz
Memory: 1022MB RAM
Page File: 1537MB used, 769MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6001.18000 32bit Unicode
Display Devices
---------------
Card name: Radeon X1300/X1550 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x7183)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_7183&SUBSYS_0D021028&REV_00
Display Memory: 509 MB
Dedicated Memory: 255 MB
Shared Memory: 253 MB
Current Mode: 1024 x 768 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Driver Name: atiumdag.dll,atiumdva.cap,atitmmxx.dll
Driver Version: 8.14.0010.0647 (English)
DDI Version: 9Ex
Driver Attributes: Final Retail
Driver Date/Size: 9/29/2009 22:42:48, 3839488 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71EE2-32C3-11CF-1F71-082DA1C2C535}
Vendor ID: 0x1002
Device ID: 0x7183
SubSys ID: 0x0D021028
Revision ID: 0x0000
Revision ID: 0x0000
Video Accel: ModeMPEG2_A ModeMPEG2_C

There are three things needed to win a war, money, money, and yet more money.
Waffentraeger
Mariner
(id: Daelon)
posted 02-23-10 02:39 AM EDT (US)     328 / 350       
Buying a dell was an upgrade? Yikes.
I bought the game at release last year. It ran generally well, and all of a sudden, it takes FOREVER to load a campaign and just freezes and lags. I've gotten fed up enough to the point where I'm just upgrading my computer.
That's not entirely your pc, ETW has a nasty habbit of hogging memory when loading into campaign, and when a turn is going.. So you might have just upgraded for nothing! Nice!
Phalanxkiller
Mariner
posted 02-23-10 07:41 AM EDT (US)     329 / 350       
Edit:

I have a dell, and I talked to my cousin. He said my graphics card barely makes it, but its fine. He did say however that I need more RAM (Don't we all? ) So I guess I'm going out to buy 2GB of RAM.

There are three things needed to win a war, money, money, and yet more money.
ellwoodis
Mariner
posted 04-04-10 00:56 AM EDT (US)     330 / 350       
I cannot run battles with this high end setup.
Please comment.
The graphics are little brown splotches even on medium setting.
The most troubling problem is that the buttons have a very long reaction time. I press button for a unit and it catches only half the time and when it does, it's 3 seconds.
That's death to cavalry.

System Information
------------------
Time of this report: 4/3/2010, 21:46:59
Machine name:
Operating System: Windows Vista™ Home Premium (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.091208-0542)
Language: English (Regional Setting: English)
System Manufacturer: HP-Pavilion
System Model: FQ565AA-ABA a6700f
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: AMD Phenom(tm) 9150e Quad-Core Processor (4 CPUs), ~1.8GHz
Memory: 3966MB RAM
Page File: 2640MB used, 5481MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6001.18000 32bit Unicode

Card name: NVIDIA GeForce 6150SE nForce 430
Manufacturer: NVIDIA
Chip type: GeForce 6150SE nForce 430
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_03D0&SUBSYS_2A6D103C&REV_A2
Display Memory: 1848 MB
Dedicated Memory: 120 MB
Shared Memory: 1727 MB
Current Mode: 1680 x 1050 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Driver Name: nvd3dum,nvd3dumx.dll,nvwgf2um, nvwgf2umx.dll
Driver Version: 7.15.0011.7574 (English)
DDI Version: 10
Driver Attributes: Final Retail
Driver Date/Size: 10/12/2008 03:12:00, 5693440 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Waffentraeger
Mariner
(id: Daelon)
posted 04-19-10 01:53 AM EDT (US)     331 / 350       
Hi ellwoodis

Your GPU is too low of quality for ETW, most likely the splotches indicates that you don't have enough vram, missing an important GPU function or your graphics aren't up to date. I have yet to hear of someone being able to run ETW with a 6150. I highly recommend you upgrade your GPU to a 9800GT series or higher.
Domoe
Mariner
posted 08-01-10 04:39 PM EDT (US)     332 / 350       
can the 512MB NVIDIA GeForce 315 or the 1GB ATI Radeon HD 5450 handle empire total war? pleas help, i am completley lost!
si3themax
Mariner
posted 08-05-10 02:28 AM EDT (US)     333 / 350       
Hi,

i'm having a fair amount of trouble running ETW on my pc and i'm unsure if my spec is the problem. One site i visited mentioned it may be an overheating issue. Essentially when i run the game it loads up fine, but as any given random point during the game my screen will lose signal and i'm forced to reboot the computer.

any advice would be appreciated.

I have an Advent, AMD Phenom 9550 Quad-core 2.20 GHz with 4.00GB ram, 32 bit operating system and if i remember correctly a GeForce 9500 or 9600 or so graphics card.

thanks
willtreaty999
Mariner
posted 08-31-10 04:05 PM EDT (US)     334 / 350       
------------------
System Information
------------------
Time of this report: 8/31/2010, 15:44:12
Machine name: USER-PC
Operating System: Windows Vista™ Home Premium (6.0, Build 6000) (6000.vista_gdr.100218-0019)
Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
System Model: HP Pavilion dv6500 Notebook PC
BIOS: Ver 1.00PARTTBL
Processor: Intel(R) Core(TM)2 Duo CPU T5250 @ 1.50GHz (2 CPUs), ~1.5GHz
Memory: 3062MB RAM
Page File: 1628MB used, 4681MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 10
DX Setup Parameters: Not found
DxDiag Version: 6.00.6000.16386 32bit Unicode


Can I run Medieval II Total War?
The Gentalmen
Mariner
posted 08-31-10 04:27 PM EDT (US)     335 / 350       
What is your video card?
willtreaty999
Mariner
posted 08-31-10 05:49 PM EDT (US)     336 / 350       
I don't know what video card I have. If you can tell me how to find out I'll post it. I was able to run Rome TW on medium/medium-high settings. I don't want to spend 20 bucks on a game I can't run halfway decent. I really appreciate your help.

[This message has been edited by willtreaty999 (edited 08-31-2010 @ 06:03 PM).]

Waffentraeger
Mariner
(id: Daelon)
posted 09-13-10 04:59 PM EDT (US)     337 / 350       
You need to post your full DxDiag.
konnaz
Mariner
posted 09-26-10 04:46 AM EDT (US)     338 / 350       
Hi Daelon, currently I run the game on low settings with a relatively smooth framerate but I feel my system is capable of more...I've posted my DxDiag (some of it) for you to look at. BTW, I'm thinking about reformatting as my PC back then ran most games on high settings and now barely scraping low, not to mention having a crapload of well...crap on my pc. Also, I am willing to upgrade my PC if you have any tips on what to upgrade. Thanks.

------------------
System Information
------------------
Time of this report: 9/26/2010, 16:38:25
Machine name: (BLOCKED IT OUT - NOT IMPORTANT)
Operating System: Windows Vista™ Home Premium (6.0, Build 6002) Service Pack 2 (6002.vistasp2_gdr.100608-0458)
Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
System Model: 965P-S3
BIOS: Award Modular BIOS v6.00PG
Processor: Intel(R) Core(TM)2 CPU 6420 @ 2.13GHz (2 CPUs), ~2.1GHz
Memory: 2046MB RAM
Page File: 1942MB used, 5774MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
DxDiag Version: 7.00.6002.18107 32bit Unicode

---------------
Display Devices
---------------
Card name: NVIDIA GeForce 8500 GT
Manufacturer: NVIDIA
Chip type: GeForce 8500 GT
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_0421&SUBSYS_82451043&REV_A1
Display Memory: 1266 MB
Dedicated Memory: 499 MB
Shared Memory: 767 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor: Generic PnP Monitor
Driver Name: nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
Driver Version: 8.17.0012.5896 (English)
DDI Version: 10
BGRA Supported: Yes
Driver Attributes: Final Retail
Driver Date/Size: 7/10/2010 06:37:00, 9818728 bytes
WHQL Logo'd: n/a
WHQL Date Stamp: n/a
Device Identifier: {D7B71E3E-4761-11CF-FB64-49A21FC2C535}
Vendor ID: 0x10DE
Device ID: 0x0421
SubSys ID: 0x82451043
Revision ID: 0x00A1
Revision ID: 0x00A1
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C
Hussarknight
Seraph Emeritus
posted 09-26-10 01:49 PM EDT (US)     339 / 350       
There's a lot you can do to give your PC a speedboost without spending any money. After some time your PC will get cluttered with all kinds of stuff, which is likely fragmented all across your harddisk.

I suggest you download CCleaner and run the various cleaning procedures it offers. Go through all the tabs and clean away. Temporary files, unnecessary background programs and faulty register-entries can all slow your computer down. Chances of CCleaner removing something you want to keep are small, but keep an eye out just in case.

          Hussarknight
konnaz
Mariner
posted 09-27-10 00:49 AM EDT (US)     340 / 350       
Thanks for the advice, but I think I am going to upgrade my cpu to a quad core and my memory by 1-2 gb. I will also reformat my PC.

Thanks for your help though

I need a sig.

[This message has been edited by konnaz (edited 09-27-2010 @ 04:39 AM).]

Negatron98
Mariner
posted 10-10-10 09:55 AM EDT (US)     341 / 350       
Just making sure but, will this run ETW?


Windows Vista Home Premium
AMD Phenom 9500
Quad Core Processor 2.20Ghz
NVIDIA Geforce 8400GS.
2Gb RAM

Thanks.

[This message has been edited by Negatron98 (edited 10-10-2010 @ 09:57 AM).]

Sarou
Mariner
posted 11-01-10 10:58 AM EDT (US)     342 / 350       
Ok, I will try to see if someone will note my point here. I have a huge problem with my Napoleon Total War game and my Empires Total War game. Both of them cause my computer to crash right when I launch the game. I don't really know why.. I will just give some basic info on my computer to see if you can tell right away:
HP Pavilion p6630f
Windows 7
Intel Core
and I got this computer new on last Thursday. I'm not really a computer genious so I don't really know what else I should say.
Waffentraeger
Mariner
(id: Daelon)
posted 11-05-10 10:09 PM EDT (US)     343 / 350       
Please read original post.
Genobee135
Mariner
posted 11-13-10 03:23 PM EDT (US)     344 / 350       
Ok, so will this work?

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
Language: English (Regional Setting: English)
System Manufacturer: TOSHIBA
System Model: Satellite L675D
BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10
Processor: AMD Turion(tm) II P520 Dual-Core Processor (2 CPUs), ~2.3GHz
Memory: 4096MB RAM
Available OS Memory: 3836MB RAM
Page File: 2337MB used, 5332MB available
Windows Dir: C:\windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7600.16385 32bit Unicode

------------
DxDiag Notes
------------
Display Tab 1: No problems found.
Sound Tab 1: No problems found.
Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D: 0/4 (retail)
DirectDraw: 0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay: 0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow: 0/6 (retail)

---------------
Display Devices
---------------
Card name: ATI Mobility Radeon HD 4200 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI display adapter (0x9712)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_9712&SUBSYS_FD001179&REV_00
Display Memory: 1914 MB
Dedicated Memory: 252 MB
Shared Memory: 1661 MB
Current Mode: 1600 x 900 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: unknown
Monitor Id: SEC544B
Native Mode: 1600 x 900(p) (59.998Hz)
Output Type: Internal
patriot229
Mariner
posted 12-16-10 03:28 PM EDT (US)     345 / 350       
Can't post dxdiag right now cause I'm at my office computer so below is my specs, let me know if I can run it or I am wasting my time.

Processor-Intel Core 2 Duo @ 1.86GHz
Video Card- ATI Radeon 5670 1GB
RAM-4 GB
Hard Drive Space-441 GB free
Waffentraeger
Mariner
(id: Daelon)
posted 12-27-10 04:13 PM EDT (US)     346 / 350       
Genobee135

Yes you can run ETW, low settings.

patriot229

Yes you can run ETW, medium/high settings.
jf28jf
Mariner
posted 03-18-11 12:37 PM EDT (US)     347 / 350       
Processor Intel® Pentium® Processor E5800
- 3.2 GHz
- 800 MHz FSB
- 2 MB L2 Cache
- Dual-core
Operating System Genuine Windows® 7 Home Premium 64-bit
RAM - 4GB installed DDR3 RAM (1066MHz)
- 4GB maximum RAM capacity
Graphics card AMD Radeon HD5450
- 1 GB dedicated DDR3 memory
Hard drive 500GB SATA 5400rpm

can i run etw and ntw on this or not?

[This message has been edited by jf28jf (edited 03-18-2011 @ 12:38 PM).]

Waffentraeger
Mariner
(id: Daelon)
posted 03-25-11 04:35 PM EDT (US)     348 / 350       
You should be able to run on med/high settings or so. Let me know.
RC1207 Sev
Mariner
posted 05-22-11 11:09 AM EDT (US)     349 / 350       
This is what I have:
Windows Vista Home Basic 6.0
2046 MB RAM
NVIDIA GeForce FX 5500
DirectX 10

Can I run?
iankinnaird94
Mariner
posted 08-20-11 08:31 AM EDT (US)     350 / 350       
hi im buying a new laptop and i was wondering if etw would be able to play on med or high settings with this laptop. Here are the specs, thanks in advance!

windows 7
Core i5
(2.66GHz)
4GB RAM
NVIDIA GeForce 310M
w/Video Memory 512MB
« Previous Page  1 ··· 5 6 7  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Empire: Total War Heaven | HeavenGames